Jump to content
Sign in to follow this  
aleshak

Přesměrování portů s jednou veřejnou IP

Recommended Posts

Ahoj, nedavno jsem si zařídil internet od UPC (40mbit) a dostal modem Technicolor 7200. Potřebuju se zvenčí dostat na svůj NAS, čili jsem modem přepnul do bridge módu a za něj dal router Netgear WNDR3800. Internet mi normálně funguje, k NASu se připojím v rámci lokální sítě bez problémů. Ale připojit se zvenčí funguje pouze v případě, že je k routeru připojeno jediné zařízení (tj. NAS). Pokud jsem připojen k lokální síti ještě notebookem, pak při pokusu připojit se na NAS z tohoto notebooku dostávám hlášku "ssh: connect to host xx.x.xx.xx port yyyy: Connection refused". Přijde mi, jakoby router přesměroval požadavek nikoliv na NAS, ale právě na notebook. V nastavení přesměrování portů mam přitom cílovou IP nastavenu správně, dříve u starého poskytovatele mi to fungovalo bez problémů a i teď se na NAS dostanu např. z práce. Problém nastane až tehdy, pokud bude někdo doma a připojí se k síti mobilem/notebookem. Netušíte někdo, čím by to mohlo být způsobené? Přijde mi, že ani bridge mód ani 1 veřejná dynamická IP adresa by na toto neměla mít vliv...

Share this post


Link to post
Share on other sites

přesměrování portů umí i přímo techniclor 7200. Stačí si jen přečíst manuál. mimochodem zlozvyk čechů, na něco si začít stěžovat a pak zjistí, že to je popsaný v manuálu :-D

  • Internet 50
  • -
  • -
  • modem technicolor
  • Brno

Share this post


Link to post
Share on other sites
Ahoj, nedavno jsem si zařídil internet od UPC (40mbit) a dostal modem Technicolor 7200. Potřebuju se zvenčí dostat na svůj NAS, čili jsem modem přepnul do bridge módu a za něj dal router Netgear WNDR3800. Internet mi normálně funguje, k NASu se připojím v rámci lokální sítě bez problémů. Ale připojit se zvenčí funguje pouze v případě, že je k routeru připojeno jediné zařízení (tj. NAS). Pokud jsem připojen k lokální síti ještě notebookem, pak při pokusu připojit se na NAS z tohoto notebooku dostávám hlášku "ssh: connect to host xx.x.xx.xx port yyyy: Connection refused". Přijde mi, jakoby router přesměroval požadavek nikoliv na NAS, ale právě na notebook. V nastavení přesměrování portů mam přitom cílovou IP nastavenu správně, dříve u starého poskytovatele mi to fungovalo bez problémů a i teď se na NAS dostanu např. z práce. Problém nastane až tehdy, pokud bude někdo doma a připojí se k síti mobilem/notebookem. Netušíte někdo, čím by to mohlo být způsobené? Přijde mi, že ani bridge mód ani 1 veřejná dynamická IP adresa by na toto neměla mít vliv...

UPC ti přidělí 1 IP a když Technicolora přepneš do bridge, tak tuto IP dostane jedno jediný zařízení a víc jich nepřipojíš. Proto je Technicolor i routerem, abys mohl mít zařízení víc.

Share this post


Link to post
Share on other sites
přesměrování portů umí i přímo techniclor 7200. Stačí si jen přečíst manuál. mimochodem zlozvyk čechů, na něco si začít stěžovat a pak zjistí, že to je popsaný v manuálu :-D

 

Zlozvykem Čechů je hlavně dělat rychlý soudy a závěry, aniž by o konkrétní věci/situaci něco věděli... Za prvý si nestěžuju a za druhý jsem manuál studoval o týhle možnosti vím, ale z určitýho důvodu je mi samotný Technicolor na nic. Pokud nemáš nějakou věcnou odpověď k mé otázce, tak sem prosím nic nepiš (další nehezký zlozvyk) :thumbdown:

Share this post


Link to post
Share on other sites

Hmm, pořád mi asi něco uniká :shock: Myslel jsem, že tu veřejnou IP dostane router za modemem, který pak požadavek správně přesměruje na dané zařízení v lokální síti (dle tabulky přesměrování portů). Dříve jsem měl Airwaynet a jednu statickou veřejnou IP adresu. Přípojka (zakončená UTP kabelem) šla přímo do routeru. K routeru bylo připojeno několik zařízení, mimojiné dva počítače, na které jsem lezl přes SSH zvenku. Podle portu šel buď požadavek na první počítač nebo druhý počítač - IP adresu jsem používal stejnou pro oba počítače. Jak je tedy možné, že to samé nejde s UPC?

Share this post


Link to post
Share on other sites

S UPC jde totéž, ale nesmíš mít ten Technicolor v režimu bridge, ale musíš ho mít jako router (a Netgear je pak k prdu). A pokud je ten Technicolor v režimu bridge a za ním máš Netgear, tak hledej chybu v tom Netgearu, kterej neroutuje a chová se jako bridge de facto taky.

Share this post


Link to post
Share on other sites

Technicolor má 4 eth výstupy a tudíž v režimu bridge dostanou, až 4 připojená zařízení veřejnou ip adresu... no a v režimu routeru stačí v upřesni a předávání nastavit nat rozsah portů od-do tam zadáš to stejné číslo pokud se jedná jen o jeden port např. 443-443

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...